Back to overview
Downtime

Juxtacloud Auckland Two, Juxtacloud Vancouver One, and 1 other service are down

Feb 08, 2026 at 04:01pm UTC
Affected services
Juxtacloud Auckland Two
Juxtacloud Vancouver One
Jellyfin

Resolved
Feb 08, 2026 at 04:07pm UTC

Juxtacloud Vancouver One recovered.

Updated
Feb 08, 2026 at 04:07pm UTC

Juxtacloud Auckland Two and Jellyfin recovered.

Created
Feb 08, 2026 at 04:01pm UTC

Juxtacloud Auckland Two, Juxtacloud Vancouver One, and Jellyfin went down.